Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 20, 2025 - 05:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 07, 2025 - 09:08 UTC
Scheduled
Hi all, We want to inform you about the maintenance of the Zephyr Cloud. The app might be briefly unavailable during that time. Please check the schedule below. We value your work, so we'll make sure the maintenance doesn't affect it. Schedule: 2025-04-20 05:30 UTC