We are experiencing degraded performance of the Zephyr API module.

Incident Report for Zephyr Cloud

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 10:01 UTC

Investigating

Impact:

API calls may be slower than usual or occasionally time out.

Current status

Our engineering team has identified the bottleneck in the API tier and is deploying optimisations now. Logs and metrics are under close review.

Next update:

We will update this message as soon as further information is available.
Posted Jul 15, 2025 - 07:05 UTC
This incident affected: Zephyr Cloud REST API(US).